Minimum system requirements for EZ-VOTE Connect:

  • Windows 7, 8 and 10 (32 & 64 Bit)
  • MS Office 2010, 2013 and 2016 (32 & 64 Bit)
  • MS .NET 4.6, MS Installer 5
  • Intel Core i5, 4GB RAM, 3GHz or better
  • USB Port (1.1 and up), 250 MB disk space


Other Requirements

No disk encryption software. No restrictions on USB ports.
User must be a local administrator with software installation privileges.

PowerPoint AutoRecovery

AutoRecovery (AutoSave) function should be disabled (via Options menu)


Security Software

Some security and hard drive encryption software may interfere with the download and installation of the EZ-VOTE Connect Suite. Disable it temporarily or add a system-wide exception/exclusion to allow for normal operation.


A/C power

If running EZ-VOTE Connect on a laptop, the computer must be plugged into A/C power source (not running on batteries).


Legacy Applications

These minimum system requirements apply to:

- EZ-VOTE 1, 2

- EZ-PRESENTER

- EZ-POLL-IT

- EZ-TRIVIA

- EZ-CATEGORIES

- EZ-SCHOLAR

- TOWNVOTE


Systems with Windows XP:

  • All current Service Packs & updates
  • Pentium 4 or better
  • 2GB RAM
  • EZ-VOTE 2: PowerPoint 2010, 2013, or 2016 (32-bit or 64-bit)
  • EZ-VOTE 1: PowerPoint 2007 (only) 32-bit or 64-bit

Did this article solve your issues? Please leave us feedback below.